Benutzer-Werkzeuge

Webseiten-Werkzeuge


Seitenleiste

Inhalt

user:sprobst

Steffen Probst

Alle hier erstellten Inhalt dieser Seiten und deren Unterseite stelle ich unter der GPLv3. Ihr dürft die Inhalte gerne im Sinne dieser Lizenz weiterverwenden.
Alle auf dieser Seite und Unterseiten veröffentlichten Bilder stelle ich unter der CC BY-NC-ND1) Lizenz, wenn dieses nicht anders angegeben wurde. Ihr dürft die Bilder im Sinne der Lizenz verwenden.
Ausgeschlossen von meiner Lizenzierung sind Bilder, Inhalte, Dokumente und Informationen, die ich über extern verlinkt habe. Auch, wenn das nicht direkt ersichtlich ist. Wenn ihr/euch nicht sicher seit, dann kontaktiert mich über meine LUG-E-Mail-Adresse.

Blog

kleine Tastenkürzelübersicht zu vi(m)

TastenkürzelBeschreibung
i Zeichen einfügen in derselben Zeile wo der Cursor steht.
o Zeichen einfügen eine neue Zeile.
x Zeichen löschen, wo der Cursor steht.
dd Zeile löschen wo der Cursor steht.
:q! vi(m) ohne zu speichern verlassen
:wq vi(m) mit speichern verlassen
2021/06/04 13:04 · SProbst

openwrt auf der Hetzner Cloud

  • Eine kurze Einrichtungsanleitung eines Hetzner Cloud KVM mit openwrt.

erste Einstellung nach reboot von openwrt

  • Netzwerkkarte eth0 für WAN konfigurieren und LAN auf eth1, dummy0 oder VLAN binden.
/etc/config/network
config interface 'wan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'dhcp'
	option peerdns '0'
 
 
config interface 'wan6'
	option ifname '@wan'
	option _orig_ifname '@wan'
	option _orig_bridge 'false'
	option proto 'static'
	option ip6ifaceid '::2'
	option ip6gw 'fe80::1'
	option ip6addr '2a01:xxxx:xxxx:xxxx::2' #IPv6 von Hetzner anpassen 
	option ip6prefix '2a01:xxxx:xxxx:xxxx::2/64' #IPv6 Prefix von Hetzner anpassen
 
config interface 'lan'
	option type 'bridge'
	option ifname 'eth1'
	option _orig_ifname 'eth1'
	option _orig_bridge 'true'
	option proto 'dhcp'
	option delegate '0'
	option defaultroute '0'
	option metric '100'
	option peerdns '0'
  • Firewall für Zugriff auf SSH einrichten
/etc/config/firewall
config rule
        option src 'wan'
        option target 'ACCEPT'
        option proto 'tcp'
        option dest_port '22'
        option name 'OpenSSH'
  • Dienste neustarten
/etc/init.d/network restart && /etc/init.d/firewall restart
2021/06/04 12:46 · SProbst

rclone - Sync mit nextcloud

2)

Gestern habe ich ein neues Programm unter Linux getestet. Im Rahmen einer Anforderung sollte automatisch Mediendateien in die Nextcloud kopiert werden. Bei meiner Internetrecherche habe ich das Programm rclone gefunden. Nach der ersten Einrichtung, was recht benutzerfreundlich ist, für ein Terminalprogramm, lief auch der Test gleich erfolgreich.
Das Programm ist sehr eingängig und ich es kann es jedem empfehlen, der Dateien in die Cloud laden möchte. rclone unterstützt nach eigenen Angaben 40 Clouds. Das habe ich nicht getestet. Aber der Upload mit Nextcloud lief einwandfrei. Es lässt sich auch wunderbar in diverse Scripte integrieren.
Eine Anleitung für die Nextcloud ist unter folgendem Link zu finden. → https://rclone.org/webdav/#nextcloud

2021/02/26 07:22 · SProbst

HP U160 Bildschirm unter Linux

Vor kurzem habe ich ein HP U160 Display ergattert. Der Bildschirm wird über USB angeschlossen und mit ca. 1A darüber mit Strom versorgt. Dank Tobias haben wir auch eine Lösung gefunden, wie der Bildschirm unter Linux angesteuert werden kann. Bei meiner Konfiguration beziehe ich mich unter anderem auf den folgenden Artikel im ArchWiki → Link. Der Artikel nimmt sich dem Thema etwas tiefer an.

Unsere Lösung sieht wie folgt aus:

hpu160.sh
OUTPUT=DVI-I-1-7
MODE="1368x768_59.90"
MODELINE='85.72  1368 1440 1584 1800  768 769 772 795  -HSync +Vsync'
 
#xrandr --listproviders
xrandr --setprovideroutputsource 1 0 #Bildschirm/Monitor Senke setzen -> Monitor muss per USB angeschlossen sein
OUTPUT=$(xrandr --current | grep DVI | cut -f 1 -d" ") #DVI Port vom USB Monitor finden (geht nur, wenn kein weiter DVI vorhanden ist)
xrandr --newmode $MODE $MODELINE #Monitor Modus definieren
xrandr --addmode $OUTPUT $MODE #Monitor Modus am DVI binden
xrandr --output $OUTPUT --mode $MODE #Monitor anschalten

Wenn Ihr das Script übernehmt, dann achtet darauf, das keine weitere DVI Monitor am PC vorhanden ist. Ansonsten müsst Ihr das Script noch anpassen. Oder Ihr schickt mir eine bessere Lösung, dann veröffentliche ich diese hier. ;)

2021/01/12 08:44 · SProbst

v4l2loopback - Videokonferenz ohne USB-Camera - mit esp32-cam

Seit längerem bin ich schon am überlegen, das Videokonferenzen/Videostream ohne USB-Webcam gehen muss. Nach etwas Recherche bin ich über diverse Ideen gestolpert, wobei eine ESP32-Cam (optional aus Rasp Pi mit Camera) reichen sollte. Anstoß gab mir die Idee von Canon, das die DLSR Kameras für Videokonferenzen mittlerweile verwendet werden könne. Hierzu habe ich auch einen Blogeintrag gefunden(siehe Links).
In diesem Zusammenhang bin ich über v4l2loopback gestolpert. Passende Beispiel findet Ihr hier im Blogeintrag weiter unten und in den folgenden Links.

Im Zusammenhang mit der esp32-cam demo musste ich etwas spielen, da ffmpeg den Datenstrom nicht auf Anhieb erkannt hat.

esp32-cam-demo Beispiel
ffmpeg -f mjpeg -i http://{ip}/stream -framerate 15 -vcodec rawvideo -pix_fmt yuv420p -threads 0 -f v4l2 /dev/video5 #Video mjpeg von esp32-cam-demo 
2020/12/26 11:57 · SProbst

Index

2019/11/13 20:08 · SProbst
1)
Namensnennung - Nicht-kommerziell - Keine Bearbeitung
2)
Logo von der Homepage von rclone.org
Cookies helfen bei der Bereitstellung von Inhalten. Diese Website verwendet Cookies. Mit der Nutzung der Website erklären Sie sich damit einverstanden, dass Cookies auf Ihrem Computer gespeichert werden. Außerdem bestätigen Sie, dass Sie unsere Datenschutzerklärung gelesen und verstanden haben. Wenn Sie nicht einverstanden sind, verlassen Sie die Website. Weitere Information
user/sprobst.txt · Zuletzt geändert: 2019/11/13 20:12 von SProbst